A long time ago, in a galaxy far,
far away....

Episode 0

LOST IN THE STACK TRACE


Ngnix is set. Docker compose spun up correctly. Tomcat is running. SpringBoot is loading classes... DataSource initialization completed. We are live! The first GETs are coming! Hurray!
But then the browser shows:

        { status: 500, message: "Exception in thread
        "main" java.lang.NullPointerException
        at com.star.wars.episode.zero.StarwarsResource
        .get(StarwarsResource.java:11)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse0(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse1(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse2(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse3(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse4(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse5(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse6(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse7(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse8(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse9(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse10(StarwarsService.java:22)
        at com.star.wars.episode.zero.StarwarsService
        .initializeUniverse11(StarwarsService.java:22)
        ...
        ..
        .
        "}
      

Let the debug begin . . .